# CLI 安装

Strapi CLI (Command Line Interface) 安装脚本是让 Strapi 在本地运行的最快方式。下面的指南是 Strapi 最推荐的安装选项。

# 准备安装

在您的计算机上需要安装以下软件:

任何 Strapi 项目都需要一个数据库。Strapi 目前支持以下数据库:

数据库 最低版本
SQLite 3
PostgreSQL 10
MySQL 5.7.8
MariaDB 10.2.7

# 创建 Strapi 项目

🤓 CLI 安装选项

以下安装指南介绍了最基本 CLI 的选项。当你创建一个新的 Strapi 项目时,还有其他的选项可以使用:

  • 使用 --quickstart 选项在快速启动模式下创建项目。
  • 使用 --template 选项创建一个带有预设的 Strapi 配置的项目 (参见 Templates).
  • 使用 --typescript 选项 (或简短选项 --ts) 来创建一个支持 TypeScript 的项目.
  • 使用 --no-run 选项将阻止 Strapi 自动启动服务器 (结合 --quickstart 使用)

有关更多可用选项,请参阅我们的 CLI 文档.

Strapi 还为初学者提供了一个 CLI 来创建一个带有预先制作的前端应用程序的项目 (参见 我们的博客文章 (opens new window)).

  1. 在终端中执行如下命令:
  1. 选择安装方式:

    • Quickstart (recommended) 使用默认数据库 (SQLite)
    • Custom (manual settings) 允许选择你更喜爱的数据库
  2. (仅自定义安装类型) 在数据库列表中,为你的 Strapi 项目选择一个数据库。

  3. (仅自定义安装类型) 为你的项目数据库起个名字。

# 运行 Strapi

启动 Strapi 应用程序,在项目文件夹下运行如下命令: